Project

General

Profile

Actions

Bug #156

closed

Childsplay base config overwritten by l10n config

Added by Jean-Michel Philippe about 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Urgent
Category:
Localization
Target version:
Start date:
05/19/2011
Due date:
05/23/2011
% Done:

100%

Estimated time:
1:00 h
Spent time:

Description

In the Russian version of DDL, the game set of Childsplay is not the same as in other languages. Indeed the Childsplay configuration file is modified in config-l10n/overwrite/ for Chinese and Russian in order to change of font (the Dustin manner font only works for the Latin alphabet). We need to remove these files and use a rewrite script instead, just to change the font. Note that this script should be useful for at least Cyrillic Serbian and Ukrainian, and maybe for Arabic and Persian too.

Actions #1

Updated by Jean-Michel Philippe about 13 years ago

  • Status changed from New to Ready for test
  • % Done changed from 0 to 100
Actions #2

Updated by Jean-Michel Philippe about 13 years ago

  • Status changed from Ready for test to Closed
Actions #3

Updated by Sergey Komkov about 13 years ago

  • Status changed from Closed to Need info
  • % Done changed from 100 to 90
  1. impossible to quit
  2. Letters app cannot start
Actions #4

Updated by Sergey Komkov about 13 years ago

3. Billiard and ping-pong have huge font and message does not fit the screen

Actions #5

Updated by Sergey Komkov about 13 years ago

4. Impossible to enter player's name
The problems reproduced in Whole DDL activity.

Actions #6

Updated by Jean-Michel Philippe about 13 years ago

I think there is an issue with fonts and keyboard on childsplay because the application is internally designed for Latin chars. Chinese people do not have this problem because they're using a QWERTY keyboard. What you can try to solve at least item 1 is:

  • open the console
  • check that you're actually typing Cyrillic chars (Shift+Alt to switch keyboard layout if required)
  • start childsplay with the command of the same name
  • do all the tests you want

This way you are sure to start childsplay with a Cyrillic keyboard. As I haven't got such keyboard, this is difficult for me to test.

Actions #7

Updated by Sergey Komkov about 13 years ago

Keyboard works but
  1. Letters app cannot start
  2. Multitable and ping-pong have huge font and message does not fit the screen
Actions #8

Updated by Sergey Komkov about 13 years ago

which is 2011-05-30

Actions #9

Updated by Jean-Michel Philippe about 13 years ago

I propose to disable the letter activity on all Cyrillic CD's. This activity should be available in other software I think.

Actions #10

Updated by Sergey Komkov about 13 years ago

the problem is in font size for 2 Childsplay apps
I don't know what's the problem with Letters app

Actions #11

Updated by Sergey Komkov about 13 years ago

Impossible to quit Childsplay

Actions #12

Updated by Jean-Michel Philippe about 13 years ago

The same for me, I was unsure whether this due to my Latin keyboard layout or not. I think Childsplay has hardcoded the letters Y and N in the exit procedure. This means we need to switch back to Latin alphabet if we don't patch this application. I noticed that the issue is happening with the second letter activity too: children are proposed to type Latin letters.

If you want to patch the application, please try to find which files of Childsplay are responsible for the exit procedure and the letter activities. You can get the list of files of each childsplay package from the Debian portal:

http://packages.debian.org/search?keywords=childsplay&searchon=names&suite=oldstable&section=all

On the bottom of each package page, there is a link “File list”. For example for the package “childsplay”:

http://packages.debian.org/lenny/all/childsplay/filelist

Actions #13

Updated by Jean-Michel Philippe about 13 years ago

  • Status changed from Need info to Closed
  • % Done changed from 90 to 100

As a workaround I removed the two letter activities on the Russian CD and the exit question. Clicking the exit button now exits without prompting.

Actions

Also available in: Atom PDF