Project

General

Profile

Actions

Bug #290

closed

Epiphany cannot reach any site

Added by Sergey Komkov almost 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Normal
Category:
Testing
Target version:
Start date:
07/04/2011
Due date:
08/29/2011
% Done:

100%

Estimated time:
1:00 h
Spent time:

Description

Epiphany cannot reach any site though ping works fine

Actions #1

Updated by Jean-Michel Philippe almost 13 years ago

It may be due to a wrong configuration of DansGuardian. Typically when DansGuardian fails to start, web pages are not reachable but networking is working. Further investigation is then needed…

Actions #2

Updated by Jean-Michel Philippe almost 13 years ago

  • Due date set to 08/29/2011
  • Status changed from New to In Progress
  • % Done changed from 0 to 20
  • Estimated time set to 1:00 h

For an unknown reason Squid and Dansguardian are not started while network is brought up, which makes any web page request fail.

Actions #3

Updated by Jean-Michel Philippe almost 13 years ago

  • % Done changed from 20 to 50

It seems the directory /etc/dhcp3/ has just moved to /etc/dhcp/ :).

Actions #4

Updated by Jean-Michel Philippe almost 13 years ago

  • Status changed from In Progress to Ready for test
  • % Done changed from 50 to 100
Actions #5

Updated by Sergey Komkov almost 13 years ago

The problem is reproduced at the latest Russia ??

Actions #6

Updated by Jean-Michel Philippe almost 13 years ago

  • Status changed from Ready for test to In Progress
  • % Done changed from 100 to 50

I figured out that it works only if you're manually invoking a DHCP lease, what I've done in my tests. If you let Network-manager do the stuff, it doesn't call DHCP directly anymore, as it did in Gondwana. I guess it is because it can now use fixed IP's, thus without any DHCP.

As a result it seems we have to make a dupe of our DHCP script in /etc/NetworkManager/dispatcher.d/. The best option seems to make it call /etc/dhcp/dhclient-exit-hooks.d/squid-dansguradian. The strange thing is that Network-manager is supposed to call ifup scripts in /etc/network/, it should then start Squid and DansGuardian but it doesn't.

Actions #7

Updated by Jean-Michel Philippe almost 13 years ago

  • Status changed from In Progress to Ready for test
  • % Done changed from 50 to 100

Our scripts were not written to start Squid/DansGuardian from if-up. It is now the case, a new custom Debian package dansguardian-squid has been created on purpose to deal with the issue.

Actions #8

Updated by Sergey Komkov almost 13 years ago

It works fine

Actions #9

Updated by Jean-Michel Philippe almost 13 years ago

  • Status changed from Ready for test to Closed
Actions

Also available in: Atom PDF