Project

General

Profile

Actions

Bug #224

open

Task #250: Improve Songwrite

Songwrite cannot handle Russian

Added by Jean-Michel Philippe about 13 years ago. Updated almost 12 years ago.

Status:
In Progress
Priority:
Normal
Category:
Development
Start date:
06/13/2011
Due date:
11/30/2012 (over 11 years late)
% Done:

50%

Estimated time:
5:00 h
Spent time:

Description

It is not possible to specify the Russian language in the song parameters. A patch is necessary but even with that, PDF exporting fails to render Cyrillic characters. We need to inform Jiba, the upstream author.


Related issues 2 (0 open2 closed)

Related to New applications - Feature #52: Create a first songbook for songwrite2ClosedJean-Michel Philippe04/27/201105/23/2011

Actions
Related to DoudouLinux CD - Bug #384: SongWrite2: print preview does not workClosedJean-Michel Philippe09/16/201109/21/2011

Actions
Actions #1

Updated by Jean-Michel Philippe about 13 years ago

  • Parent task changed from #44 to #250
Actions #2

Updated by Jean-Michel Philippe almost 13 years ago

  • Due date set to 08/29/2011
  • Status changed from New to In Progress
  • Assignee set to Jean-Michel Philippe
  • % Done changed from 0 to 50

The issue has been reported upstream and the author has been working on the integration of as many languages as possible, referring to the whole Latex/Babel language set. See:

http://svn.gna.org/viewcvs/songwrite?view=rev&revision=296

The very first trials made showed that Russian texts are correctly displayed in the interface and in PDF scores, under the staffs. Unfortunately there are still issues for lyrics in the PDF output.

Actions #3

Updated by Jean-Michel Philippe almost 13 years ago

  • % Done changed from 50 to 80

The error message while compiling the (Russian) PDF score is the following:

(/usr/share/texmf-texlive/tex/latex/cyrillic/t2acmr.fd)
*geometry auto-detecting driver*
*geometry detected driver: dvips*
LaTeX Font Warning: Font shape `T2A/aer/m/n' undefined
(Font)              using `T2A/cmr/m/n' instead on input line 11.

Investigations on the Internet showed that this is a problem of font declaration. The solution is to edit /usr/share/texmf-texlive/tex/latex/cyrillic/t2acmr.fd then add the following lines:

\DeclareFontFamily{T2A}{aer}{}
\EC@family{T2A}{aer}{m}{n}{larm}

Just before the declaration of the font “cmr” for example.

We need to report this issue and its solution to Debian!

Actions #4

Updated by Jean-Michel Philippe almost 13 years ago

  • Status changed from In Progress to Ready for test
  • % Done changed from 80 to 100
Actions #5

Updated by Jean-Michel Philippe over 12 years ago

The bug has now been reported to Debian:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=647225

Actions #6

Updated by Jean-Michel Philippe over 12 years ago

  • Status changed from Ready for test to Closed
Actions #7

Updated by Jean-Michel Philippe over 12 years ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 70
  • Estimated time changed from 2:00 h to 3:00 h

The upstream author has patched his code:

http://svn.gna.org/viewcvs/songwrite/trunk/songwrite2/plugins/ps_native/ps_latex.py?r1=315&r2=314&pathrev=315

However the problem is now that lmodern is a very huge package (17 MB) and we just need one font in it. Moreover, lmodern may not fit non-Latin and non-Cyrillic languages. It would then be better to add a fix that allows for specifying which font to use for a given language. For example the package texlive-lang-cyrillic provides Cyrillic fonts and only weights less than 5 MB. Its font lcy has been successfully used to produce Russian PDF scores with lyrics.

Actions #8

Updated by Jean-Michel Philippe over 12 years ago

  • Due date changed from 08/29/2011 to 11/28/2011
  • Target version changed from 2011-08 to 2011-11
Actions #9

Updated by Jean-Michel Philippe over 12 years ago

  • Due date changed from 11/28/2011 to 02/20/2012
  • Target version changed from 2011-11 to 2012-02
  • % Done changed from 70 to 50
  • Estimated time changed from 3:00 h to 5:00 h
Actions #10

Updated by Jean-Michel Philippe about 12 years ago

  • Target version changed from 2012-02 to 2012-08
Actions #11

Updated by Jean-Michel Philippe almost 12 years ago

  • Due date changed from 02/20/2012 to 11/30/2012
  • Target version changed from 2012-08 to 2012-11
Actions

Also available in: Atom PDF